constantinmedia Blog

Just another guy blogging…



Windows 8 auf dem Schenker Notebook XMG A722 ADVANCED

Update: Schenker hat sich mittlerweile bei mir gemeldet und mir mitgeteilt, dass es inzwischen ein BIOS-Update und entsprechende Treiber für Windows 8 gibt. Ich konnte es aus Zeitgründen (und ein Bisschen auch aus Angst, das System zu zerschießen, und den Laptop nicht mehr benutzen zu können, auf den ich derzeit zum Arbeiten angewiesen bin… ;)) noch nicht selbst ausprobieren, werde das aber bei Gelegenheit tun und dann hier berichten.

Über mySN.de kann man sich Notebooks nach eigenen Vorstellungen zusammenstellen, die dann (in Deutschland) individuell für einen gefertigt werden. Auf diese Weise habe ich versucht, die Balance zwischen Business- und Gaming-Notebook zu halten, was mit einem Laptop für den Massenmarkt eher nicht möglich gewesen wäre. Dieser Post soll aber kein Erfahrungsbericht über die Firma oder die Hardware werden (soweit bin ich mit dem Gerät und dem Support sehr zufrieden).

Windows 8 ist offiziell für den 26. Oktober 2012 angekündigt, als Entwickler hat man über entsprechende Firmen-Zugänge aber schon jetzt Zugriff auf die so gut wie finale Version – und da dachte ich mir: „Wenn schon neues Notebook, dann auch gleich mit der neusten Windows-Version“. Diese Stellung als „Early Adopter“ bringt aber natürlich auch ihre Schwierigkeiten mit sich, wie ich feststellen musste… ;) Eines Vorweg: Es ist möglich, Windows 8 zufriedenstellend auf (zumindest diesem Modell, wahrscheinlich aber auch allen neueren der) Schenker Notebooks zum Laufen zu bekommen. Allerdings bleibt dabei immer ein „Geschmäckle“, dass eben etwas Frickelei nötig war. Das klingt jetzt nach einigen Tagen der Benutzung aber schon ab.

Während meiner Versuche, das zum Laufen zu bringen, konnte ich kaum Informationen im Netz finden. Weder auf Deutsch noch auf Englisch schien jemand das schon mal versucht zu haben und auf die gleichen Probleme und Fehlermeldungen gestoßen zu sein. Deshalb hier ein kleiner Erfahrungsbericht und Guide, wie man die Fehler beseitigen und Windows 8 auf der Hardware zum laufen bekommen kann.

Das Problem: Die Treiber

Windows 8 war so schnell installiert, dass ich zunächst gar nicht sicher war, ob es das jetzt schon war, oder ob das nur eine Einführung ist, während im Hintergrund die Installation weiterläuft. Als ich dann aber auf dem neuen Windows 8 Kachel-Startbildschirm angelangt war, habe ich erst mal versucht, Kontakte und Kalender etc. zu verbinden. Allerdings hing ich dann irgendwie in einem Endlos-Loop aus „Noch keine Account bei Microsoft hinterlegt“ und „Es besteht keine Internetverbindung um mich anzumelden“ fest. Bestimmt wäre ich da irgendwie auf normalem Wege wieder herausgekommen, aber da ich von der Funktionsweise von Windows 8 noch keine Ahnung hatte, habe ich mir mit Windows+D geholfen, um auf den normalen Windows-Desktop zu gelangen. Das wusste ich zum Glück, dass das möglich ist.

Im Gerätemanager (Windows+Pause) habe ich dann auch gleich gesehen, dass bei vielen Hardwarebestandteilen ein gelbes Ausrufezeichen zu sehen war, also die Treiber nicht korrekt installiert werden konnten. Unter anderem war auch der WLAN-Adapter betroffen, was natürlich erklärte, warum keine Internetverbindung bestand. Kurzerhand das Ethernet-Kabel angeschlossen, was dann zum Glück auch funktioniert hat. Per Windows Update konnten dann zumindest die Grafikkartentreiber (wenn auch veraltete, die ich später selbst aktualisieren musste) installiert werden. Touchpad (hier gingen nur die Grundfunktionen, aber kein Scrollen oder ähnliches), WLAN usw. wurden aber nach wie vor nicht gefunden. Kein Problem, dachte ich, es liegt ja eine Treiber-CD bei, wahrscheinlich ist die Hardware einfach nur zu spezifisch, was ja bei Notebooks gerne mal der Fall ist.

Treiber-CD rein, Autorun gestartet – und der Installer begrüßte mich mit der folgenden Meldung:

Fehlermeldung bei Start von autorun.exe (Treiber-Installations-Tool von Schenker)

Error: Home -> On Preload, Line 47: Argument 2 must be of type string.

Nach Klick auf „OK“ erschien dann trotzdem der Startbildschirm mit den Optionen „Install Drivers“, „Option Drivers“, „User’s Manual“, „Browse CD/DVD“ und „Exit“. Also auf „Install Drivers“ geklickt, und sofort wurde jegliche Hoffnung mit der folgenden Meldung zerstört:

Fehlermeldung bei autorun.exe Option "Install-Drivers"

Warning: OS you are using can not be supported!!

Man beachte die zwei Ausrufezeichen hinter der Meldung – Verdammt. Die meinen es ernst. Da saß ich also, vor meinem nigelnagelneuen Notebook und hatte weder ein richtig funktionierendes Touchpad, noch WLAN (äußerst Sinnvoll bei einem Notebook… ;)) und einige andere Systemkomponenten hatten auch keinen richtigen Treiber. Ich war schon dabei, mir Windows 7 auf den Stick zu ziehen, um es damit zu versuchen, denn die Fehlermeldung schien mir recht eindeutig. Nach erfolgloser Suche im Netz kam mir dann über einen eigentlich unzusammenhängenden Artikel die Idee: „Kompatibilitätsmodus!“.

Das geht so einfach wie vorher unter Windows 7 schon mit Programmen, die für Windows XP oder älter gedacht waren. Rechtsklick auf die Datei, -> Eigenschaften -> Kompatibilität, Häkchen beim Kompatibilitätsmodus auswählen und „Windows 7“ aus dem Dropdown selektieren. (Im Screenshot ist allerdings alles auf Englisch, bei englischen Sprachversionen Rechtsklick -> Properties -> Compatibility -> Compatibility mode)
autorun.exe im Windows-7-Kompaitibilitätsmodus

Zusätzlich empfehle ich, das Programm auch mit Administratorrechten starten zu lassen (entweder direkt hier im Dialog einstellen, oder per Rechtsklick auf die Datei). Sicher ist sicher.

Und siehe da: Es klappt tatsächlich! Die Architektur von Windows 7 zu Windows 8 scheint sich nicht all zu dramatisch verändert zu haben, und so lassen sich die meisten Treiber unter „Install Drivers“ und „Option Drivers“ jetzt über das Installations-Tool installieren. Nur bei einigen wenigen passiert entweder nichts, oder es kommt noch zu Fehlermeldungen. Hier kann man Abhilfe schaffen, wenn man sich im Ordner „/Driver“ bzw. „/Options“ in den entsprechenden Unterordner hangelt, und für diesen Installer auch wieder den Kompatibilitätsmodus für Windows 7 aktiviert (siehe oben). Bei welchen Treibern das genau nötig war, weiß ich leider nicht mehr, man findet das aber leicht heraus, wenn bei einem Punkt aus dem Installationstool einfach nichts geht oder Fehler auftreten! ;)

Das einzige, was ich auch so nicht zum Laufen bekommen habe, ist „9. Install Rapid Start Driver“ (und logischerweise die Treiber für Hardware, die in meinem Modell gar nicht installiert ist, wie „3G“ oder „Finger Print Driver“). Bei 15 Sekunden Startzeit von Windows 8 in Verbindung mit einer SSD als Systemlaufwerk kann ich darauf aber auch verzichten. Außerdem – jetzt mal eine gute Nachricht – hat man mir auf Anfrage beim Schenker-Support folgendes mitgeteilt:

Wir können Ihnen jetzt schon mal sagen, dass es definitiv offizielle Windows-8-Treiber von uns geben wird – nur der Zeitpunkt der Veröffentlichung steht noch nicht fest.

Vielen Dank an dieser Stelle für die schnelle Antwort, obwohl ich eine ewig lange Mail geschrieben hatte, die sicherlich einige Zeit zum Lesen in Anspruch genommen hat! ;-)

Dann wird also voraussichtlich alles viel einfacher werden und wahrscheinlich auch der „Rapid Start Driver“ zum Laufen zu bringen sein. Ich bin gespannt, ob man die Anpassung der Treiber schon bis zum offiziellen Release von Windows 8 schafft, es bleibt jetzt ja noch weniger als ein Monat.

Ich hatte noch einige weitere Probleme, die ich in meiner umfangreichen Support-Anfrage geschildert habe. Zum einen sind bei meiner Tastatur die Windows- und Alt-Tasten etwas lauter als die anderen Tasten und haben einen leicht „knackigen“ Druckpunkt, aber man hat mir beim Support zugesichert, dass dieses Verhalten „innerhalb der Spezifikationen liegt“, und für mich ist das auch kein Grund ist, das Gerät einzuschicken, wenn sich das nicht verschlechtern und die Tasten unbrauchbar machen sollte.

Nachdem Windows 8 nun also läuft (und soweit ich das jetzt schon beurteilen kann, ohne Probleme im System oder mit Hardware-Komponenten), galt es noch zwei weitere Probleme zu beseitigen.

Festplatte als physisches Laufwerk verwenden statt über „Storage Spaces“

Meine zusätzliche Zweitfestplatte tauchte von Anfang an nicht im Explorer auf, obwohl ich sie im BIOS und im Boot-Menü angezeigt bekam. Eine technischenr Defekt war somit nahezu auszuschließen und es musste etwas mit Windows 8 zu tun haben. Dass die Festplatte noch nicht formatiert war, schien klar, aber sie wurde auch nicht in der Datenträgerverwaltung (Disk Manager) aufgeführt, um sie dort auf NTFS zu formatieren. Über das Tool von Intel, welches ich ja mittlerweile installieren konnte, wurde die Festplatte aber ebenfalls erkannt. Auch hierzu konnte ich im Netz nichts finden und es schien zunächst, als könnte ich die Festplatte unter Windows 8 nicht nutzen.

Allerdings las ich etwas über die neue Funktion namens „Storage Spaces“ in Windows 8, die folgendermaßen funktioniert: Mehrere Festplatten können zu einem virtuellen Verbund zusammengefasst und dann unter einem Laufwerksbuchstaben unter der zusammengerechneten Größe (bzw. bei Verwendung von Datensicherung per Redundanz der Hälfte oder weniger) genutzt werden. Beim Anlegen kann die Größe sogar höher sein als die der tatsächlich verbauten Festplatten zusammen, und Windows meldet dann, sobald der Platz knapp wird, dass man weitere Platten hinzufügen soll. Während der Zusammenschluss wie bei RAID-Systemen ansich ja noch sinnvoll erscheint, erschließt sich mir der Sinn hinter dem größeren reservierten Platz und anschließender Erweiterung nicht so ganz, aber was soll’s… ;) Für ein Desktop-System mag das noch nach einer guten Idee Klingen, aber bei einem Laptop, wo ich sowieso keine weiteren Festplatten hinzufügen kann, ist das witzlos

Ich fand dann heraus, dass die Platte an dieser Stelle erkannt und einem Storage Space hinzugefügt werden konnte. Dadurch tauchte sie im Explorer auf und wurde nutzbar, aber abgesehen davon, dass es für ein Notebook mit ausgereizter Plattenkapazität nicht wirklich einen Vorteil bringt, ergibt sich dadurch folgendes Problem: Die Zweitplatte kann ich über ein Fach auf der Unterseite theoretisch entnehmen. Wenn ich die Daten aus irgend einem Grund mal auf diese Weise sichern müsste, würde sie aber wahrscheinlich unter älteren Windows-Systemen (geschweigedenn unter Linux, was ich gerne für Zwecke der Datenrettung nutze, weil hier einfach mehr zu machen ist) gar nicht erkannt werden und die Daten darauf wären somit verloren. Windows 8 formatiert für die Zwecke der Storage Spaces nämlich die Festplatten mit einem anderen Dateisystem. Ich wollte also unbedingt die Festplatte ganz gewöhnlich als physisches Laufwerk verwenden – nur wie?

Im Endeffekt war es wohl nur meine Blindheit aufgrund der Gesamtsituation (neues Gerät und es läuft alles nicht wie es soll…), aber die Lösung ist ganz einfach: Die Festplatte war aus irgendwelchen Gründen automatisch in einen Storage Pool (also einen festgelegten Verbund von Storage Spaces) eingebunden, bzw. es ist nicht auszuschließen, dass ich das sogar selbst gemacht habe, ohne zu wissen, was ich tue. ;) Man fügt die Festplatten, die man verbinden will, erst mal zu so einem Storage Pool zusammen. Dann sind sie aber noch nicht verfügbar, sondern es muss erst festgelegt werden, auf welche Art und Weise (redundant oder mit vereinter Speichergröße) und mit welcher Zielgröße man sie zusammenlegen will. Ich musste sie also einfach nur aus dem Pool nehmen, nachdem ich die „Zusammenlegung“ (war ja nur eine Festplatte) wieder aufgehoben hatte. Diese Möglichkeit hatte ich schlicht übersehen.

Und schon konnte ich die Festplatte wie gewünscht in der Datenträgerverwaltung in NTFS formatieren und ihr einen Laufwerksbuchstaben zuteilen.

Kein Sound nach Aufwachen aus dem Standby

Ein weiteres ärgerliches Problem, mit dem ich den Laptop auch nicht weiter unter Win8 hätte betreiben wollen: Nach dem Aufwachen aus dem Sleep-Modus war plötzlich kein Ton mehr zu hören, was sich nur durch einen Neustart beheben ließ. Im Internet konnte ich dazu nur herausfinden, dass dieses Problem mit der Realtek HD Audio Hardware seit Jahren besteht und es angeblich noch keine Lösung dafür gibt. Mir war außerdem aufgefallen, dass „THX TruStudio Pro“, ein Programm zur Verbesserung der Audioqualität auf Notebook-Lautsprechern, keinen Effekt zeigte. Egal ob komplett deaktiviert oder mit niedrigsten oder höchsten Einstellungen der einzelnen Klangoptionen, man hörte einfach keinen Unterschied. Wenn der Sound ausblieb, war aber im Windows-Soundmixer immer noch ein Ausschlag der Balken zu sehen, sobald Sound hätte kommen sollen. Anscheinend wurden nur die Lautsprecher nicht richtig angesprochen.

Ich habe mir dann auf der Website von Realtek die neusten Audiotreiber besorgt und diese statt der mitgelieferten installiert. Und siehe da: Das Problem ist behoben, ich habe Sound, egal ob ich den Rechner ganz herunterfahre oder nur die Klappe zu mache und ihn somit in den Standby versetze und dann wieder aufwachen lasse.

Ich weiß nicht, ob es an der neusten Version liegt, da in den Forenbeiträgen berichtet wurde, dass das Problem damit auch nicht behoben sei… Vielleicht liegt es auch daran, dass man die Audiotreiber nach Installation des THX-Tools nochmal installieren muss? Wie auch immer: Es läuft. Und „THX TruStudio Pro“ läuft jetzt auch und ich muss sagen, ich bin überrascht. Es handelt sich hier nicht nur um Marketing-Blablubb, sondern das Tool lässt den Sound tatsächlich klarer, weniger blechern und satter aus den Boxen kommen. Klar, es ginge sicher besser und das Modell ist mit Sicherheit nicht vorne dabei, wenn es um Klang geht. Aber wenn überhaupt, höre ich Musik auf dem Laptop eher nebenher oder aber über Kopfhörer. Bei eingestecktem Kopfhörer sollte man die Surround-Funktion des THX-Tools dann aber besser deaktivieren oder zumindest auf ein erträgliches Maß heruntersetzen.

Gefixt habe ich das mit dem Sound übrigens erst bekommen, nachdem ich die Mail an den Support schon verschickt hatte. Hier ging man in der Antwort „davon aus, dass sämtliche der beschriebenen Probleme auf Win8-Treiber-Probleme zurückzuführen sind“. Und da der neue Treiber von der Realtek-Seite auch explizit Windows 8 in der Beschreibung angibt, kann es schon damit wirklich zusammenhängen.

Brummender Kopfhörerausgang

Gerade ist mir aufgefallen, dass ich den Sound per Kopfhörer noch gar nicht getestet hatte, was ich vor dem Posten noch schnell nachgeholt habe. An der Soundqualität ist mit entsprechenden Kopfhörern nichts auszusetzen. Verschiedene THX-Effekte sollte man aber dabei herunterregeln, das habe ich oben auch angemerkt. Allerdings ist mir ein ganz leises, aber für meine Begriffe noch störendes Brummen auf den Kopfhörern aufgefallen. Zufällig habe ich festgestellt, dass dieses Brummen dann aufhört, sobald ich mit dem Finger die Mikrofon-Buchse berühre. Ich kenne mich da zwar nicht so gut aus, aber irgendwas mit Masse-Brummschleife habe ich da im Kopf… ;) Deshalb habe ich dann das Ladekabel abgezogen und das Brummen hat sofort aufgehört, auch ohne Berühren des Mikrofoneingangs. Ich werde mich diesbezüglich nochmal an den Support wenden. Ich weiß nicht, ob es mir den Aufwand wert ist, das Gerät einzuschicken und dann wieder alles neu aufsetzen zu müssen… Vielleicht hilft es ja, irgendwas auf den Ausgang zu kleben oder einen Adapter-Stecker als Dummy reinzustecken… Ist zwar schade, weil das bei einem Gerät dieser Preisklasse eigentlich nicht nötig sein sollte, sich mit so etwas zu behelfen… Aber mal abwarten, was der Support sagt.

Probleme mit USB3.0

Ein weiteres Problem, dass mein USB3.0-Stick nur an 2.0-Ports erkannt wird, umgekehrt aber USB2.0-Sticks auch am 3.0er-Port problemlos Laufen, muss ich noch weiter untersuchen. Allerdings gestaltet sich das mangels weiterer USB3.0-Hardware etwas schwierig – es ist absolut nicht auszuschließen, dass es ganz einfach auch am Stick liegt!! Ich werde den Stick bei Gelegenheit an einem anderen Rechner mit USB3.0-Port testen. Mal sehen, wie es damit weitergeht.

 

Ich bin gespannt, ob es dabei jetzt erst mal bleibt, oder ob mir (hoffentlich nicht!) noch weitere Probleme auffallen. Anspruchsvolle Anwendungen und Gaming habe ich bisher noch nicht ausgereizt. Bei Minecraft ging der Lüfter ganz schön ab, was aber wohl eher der Java-Umsetzung geschuldet sein wird, da hier auch bessere Desktop-Rechner die Lüftung der Grafikkarte scheinbar grundlos hochdrehen. Warm wird aber selbst dabei außer dem Bereich um den Akku nichts. HDMI funktioniert problemlos, alles läuft flott… Vorerst bin ich also mal zufrieden mit meinem neuen Spielzeug! :)

Wenn der Post für euch hilfreich war, oder ihr selbst weitere Tipps habt, dann hinterlasst gerne einen Kommentar. Vielleicht kann ich auch bei den ein oder anderen Problemen Rat geben.


War dieser Post hilfreich für Dich? Dann darfst Du dich gerne bedanken, indem Du mir einen Kaffee in Form einer PayPal-Donation spendierst! :-)
Spenden mit PayPal: $ USD | £ GBP | € EUR

, , , , , , , , , , , ,

7 thoughts on “Windows 8 auf dem Schenker Notebook XMG A722 ADVANCED
  • Leon Bethke sagt:

    Hey, ich hab mir letzte Woche auch ein Schenker Notebook gekauft (auch das A722). Ich hab dank meiner Schule die Möglichkeit Win8 Kostenlos (MSNDAA) zu bekommen. Habs auch gleich auf das Notebook raufgespielt. und exakt die gleichen Probleme wie du :D

    Also dein Post ist genau das was ich gebraucht hab :) vielen Dank sehr Hilfreich!!

    Ich hab noch ein Problem und zwar der Knopf „VGA“, wenn ich drauf drücke passiert einfach nichts. Weißt du vielleicht woran das liegen kann? Im Internet kann ich nichts finden und hab jetzt schon ein ganzen Abend daran rumprobiert und keine Lösung gefunden.

    • Constantin sagt:

      Hi Leon,

      Inzwischen gibt es von Schenker ein BIOS-Update und extra Windows8-Treiber, die du hier herunterladen kannst:
      http://mysn.de/driver/XMG/XMG_A522_und_A722/
      Am besten führst Du eine komplette Neuinstallation durch statt eines Updates.

      Der VGA-Knopf sollte von Orange nach Grün wechseln, wenn Du ihn betätigst. Eventuell hast Du den passenden Grafiktreiber vergessen, aber nach der Win8-Neuinstallation sollte auch das funktionieren.

      Viele Grüße
      Constantin

      • Leon Bethke sagt:

        Vielen Dank werde ich heute Abend ausprobieren!

        Viele Grüße
        Leon

        • Leon Bethke sagt:

          Habs ausprobier und erstmal das BIOS Update gelassen da ich mich damit nicht auskenne und mich da auch nicht wirklich ran traue :D

          Aber dank der Windows 8 Treiber und der Neuinstallation von Windows 8 hat alles funktioniert.

          Vielen Dank für deine Hilfe!!

          Leon

  • Martin sagt:

    Vielen, vielen Dank für diesen wirklich umfangreichen und hilfreichen Beitrag :).

    Ich persönlich halte enorm viel von den Notebooks von Schenker – bzw. eigentlich von Clevo, die ganzen Barebone-Hersteller unterscheiden sich ja eigentlich nur im Service.

    Ich kann ein P502 mein Eigen nennen und bin ausgesprochen zufrieden damit :). Ich bin allerdings bei Windows 7 geblieben (und hatte damit auch keine Treiber-Probleme), denn Windows 8 folgt mal wieder Microsofts Regel von alternierend guten und verkorksten Windows-Versionen ;).

  • […] Längerem mit dem Gedanken, mit ein Tablet zuzulegen. Ich bin zwar immer noch sehr zufrieden mit meinem Schenker XMG A722, aber es ist eben nicht gerade ein leichtgewicht, und abgesehen von der Schlepperei würde ich […]

Schreibe einen Kommentar zu Leon Bethke Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.